July 22, 2018, 09:01:09 am
Welcome, Guest. Please login or register.
143596 Posts in 17277 Topics- by 29663 Members - Latest Member: Teknomage01
Pages: [1] 2 3 ... 10
 1 
 on: Today at 01:59:57 am 
Started by Kelseran - Last post by Moograne
Progressing during the summer? Damn, props BiS.

 2 
 on: Today at 01:07:00 am 
Started by Lokka - Last post by Argif
Yeah, it's alive again. Woohoo  Grin

 3 
 on: July 21, 2018, 09:52:37 pm 
Started by Lokka - Last post by Lokka
http://realmplayers.com

Happy nostalgia

 4 
 on: July 21, 2018, 09:07:25 pm 
Started by Moohiem - Last post by Fadeas
You could do most of the MC bosses with 20-25 man multiboxing team.

 5 
 on: July 21, 2018, 09:04:43 am 
Started by eether420 - Last post by Wingedhussar
Hello there,

Thank you for the information. Admins were notified. The issue is going to be fixed as soon as possible so please be patient.

Regards

 6 
 on: July 21, 2018, 05:39:39 am 
Started by Moohiem - Last post by Moograne
I don't multibox but I'd be happy to help with MC, I have a t2 tank, t3 healer, pre-aq40 BiS warlock

 7 
 on: July 21, 2018, 05:38:17 am 
Started by eether420 - Last post by Moograne
Yep, it just happens sometimes.

VG blames XT100, XT100 blames VG. It's a cute lil' meme

 8 
 on: July 20, 2018, 07:00:36 pm 
Started by eether420 - Last post by BestFCEU
Its a recurring issue on VG sometimes only 2/3 work.  Sometimes its the adblock on your pc, sometimes its an issue with the vote sites themselves.

If you're alliance side and want to supplement your income due to the loss of vote coins. There is a nice capitalist fellow who will gladly buy all of your Dreamfoil, Silversage @ 35g/stack and Icecap @ 25g/stack cod to "aboveminus" if i remember correctly

 9 
 on: July 20, 2018, 06:29:52 pm 
Started by eether420 - Last post by eether420
Bad news everyone!

       I and some of my guildies are having troubles with voting. I am personly not getting any credit for voting on xtremetop100 whereas some of my guildies will not get credit for two or all three sites.

I know it is not an IP issue as I have experienced this when trying to vote at work.

Is anyone else experiencing this issue? is this something that can be fixed?

 10 
 on: July 20, 2018, 05:34:36 pm 
Started by Kelseran - Last post by TheZus
Congrats BiS!

Pages: [1] 2 3 ... 10